Helpful Information
 
 
Category: BSD Help
Network Change

I don't think I have configured my network settings correctly. How can I change this, go into the kernel and do it that way?

FreeBSD 4.4

Also, if there is an action going (like pinging) how can I stop it?

Acutally, I guess I am able to try and get files from the internet but I tried to get http://www.apache.org/dist/httpd/httpd-2_0_28-beta.tar.gz and I get this error:


fetch: httpd-2_0_28-beta.tar.gz: open(): Permission denied

I know this files exist and I can download it using my windows side. Any hints?

For network setting, for a permanent setting, configure it in /etc/rc.conf. Look for default sample at /etc/defaults/rc.conf.

To stop ping, just type Ctrl + C like you would normally do in Windows.

Just cd to /usr/ports/www/apache2, then type make fetch. When you are ready to install it, just run make install.

You are urged to stick with Apache13.

when I do either make fetch or make install I get errors that would tell me that the files needed to fetch apache13 is nonexistent (file not found, not logged in, moved permanetly, Operation Timed out, undefined error 0.....). any hints on this now?

You have a network problem. Like I always said, there are at least 100 essential steps you should first configure before installing anything.

freebsd,

I opened rc.conf and changed it to what I think it is going to work. My documentation from a site when I searched for the commands on google.com doesn't have how to save. How do I save and return to the command prompt?

try using ee to edit your conf files. it is very simpel and then you are done editing things pres [enter] + [esc] and it will ask you to save the changes or not, just like windows. You could also use vi, it is just a little more advanced then ee.

/
UranHjort

isn't there a such thing as a default editor? Isn't vi the default? How do I make ee the default editor?

If there isn't a such thing, how to I access ee? I looked and they said to use
ee /etc/rc.conf but I get this error
ee: not found

try 'edit /etc/hosts', although ee and edit is the same, and I dont think it'll work but its worth a shot. I believe, default editor is set in .profile
UranHjort, you got it other way around, it is [esc]+[enter]

edit didn't work either

Use the vi then, whats the deal? If you do not know how to use it, just search google, its not that complicated.

when I search google, I sometimes get thousands. I can narrow it down but it is still hard to find things sometimes. I thought how to do it but then I tried it and didn't work.

Mizzory:

Try entering "/usr/bin/ee" to open ee. If this doesn't work, then I don't know how you managed to install FreeBSD without ee. It's a standard on FreeBSD systems. It doesn't depend on what your default editor is.

You might try entering "locate /ee". (You might first have to run " /usr/libexec/locate.updatedb &") This will return the location of any file starting with "ee" on the system.

For basic vi usage, just remember these 5 things:

1. Vi starts in a "command" mode, not in an editing mode. To enter other modes, you enter keys or key combinations. To exit back to command mode, you hit the ESC key.

So...

2. You cannot start editing text until you have hit the "i" key (for insert).

3. You cannot get out of text editing mode until you hit the ESC key.

4. You can enter delete mode by hitting the Delete key once, and then using the Delete key as normal. Again, exit to command mode by using the Esc key.

5. From command mode, you can quit by entering ":q!". (This will exit without saving changes). To save the current file, you can enter ":w". To save the current file as a new file, use ":w filename".

This can get you in and out of vi. The rest you can learn later.

Little note, to quit and save your info use ZZ in command mode.
I would recommend to read Oreilly's "Learning vi"

I am at the command prompt after it asks me to enter the shell... I cannot just use vi or ee or edit... how am I supposed to edit files to fix this?

I am at the command prompt after it asks me to enter the shell After what asks you to enter the shell?

Did it fail during boot and prompt you to enter the command shell as single-user to fix the filesystem?


Using Virtual PC to use both Operating Systems at once!! This might be the key to your problems. Rather than pushing your luck with these "multiple OS" systems, why not just find a cheap used computer, and put FreeBSD on it alone? (Look around, and you can probably find a Pentium 100 with 64 MB Ram for about $80)

I got it!!!

I ran fsck

went through and it found some errors... I got to the # prompt and typed exit... after a few things, it asks me to login!!!

So it WAS a boot failure. The question is "how did your filesystem get corrupted?". Did you shut down without halting the system?

I suspect this VirtualPC thing might be the cause of this and future troubles, though, so my recommendation above still stands.