Helpful Information
Category: Access
access > odbc > mysql | locked table?

hopefully someone can help me... i'm flustered...

i have a mysql db and an odbc connection setup to it under user root.
i need the odbc connection so i can have connectivity in access 2000.
select queries work fine. i can view the tables in access etc.

however update queries won't work for me. i know last week it worked, and this evening after it not working i opened up another copy of the database and it worked on that one... but only once, i went back and it didn't work in that one either.

and for the life of me i cannot figure out what would be different with the database now.

the error i'm getting is just the generic: "can not update 3 records due to lock violations"

however, what is locking odbc/access out of the mysql db? is it mysql? is it odbc? or is access locking the records? im sure it isn't mysql, and i think it is odbc but i don't know where. i downloded new drivers for odbc. i thought about updating the access jet engine but couldn't find updates...

my update query is as simple as:

"UPDATE table SET [table].[status_id]=4 WHERE [table].[order_number]='27241';

[trying to run that from access via odbc]


ok, i've determined it is only one table that is has locked me out of... not sure why

privacy (GDPR)